# CVE-2026-78681: NLTK before 3.10.3 Entity Expansion DoS via ElementTree

> Attackers can cause denial of service in NLTK by sending crafted XML payloads that trigger excessive entity expansion during parsing.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-78681, ECHO-2035-7342-4fb1, GHSA-97qj-x29f-37w7, MINI-r7fm-rx7v-v666, PYSEC-2026-3748

## What is CVE-2026-78681?

CVE-2026-78681 is a high-severity denial of service vulnerability in nltk, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK versions before 3.10.3 use xml.etree.ElementTree to parse XML in multiple modules, which honors entity declarations in document DTDs. Attackers can craft XML payloads with nested entity declarations that expand from hundreds of bytes to megabytes in memory, causing denial of service.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2026-78681?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |

Products: Nltk Nltk.

## How do I fix CVE-2026-78681?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-78681 being exploited?

There is no known exploitation of CVE-2026-78681 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78681 and fix it if it is affected.

What it is: CVE-2026-78681 is a high-severity denial of service vulnerability in nltk, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-78681 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78681/ (Markdown: https://insights.sbomify.com/CVE-2026-78681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78681
- OSV: https://osv.dev/vulnerability/CVE-2026-78681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78681/
Summaries are generated and may contain mistakes; the official description above is the record.
