# CVE-2026-78683: NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization

> Attackers can execute arbitrary code by tricking applications into loading malicious model files via unsafe pickle deserialization in NLTK.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-78683, ECHO-4f4f-fb61-1650, GHSA-rhp5-r9x4-f5g2, MINI-hmvw-744c-g4rh, PYSEC-2026-3734

## What is CVE-2026-78683?

CVE-2026-78683 is a critical unsafe deserialization vulnerability in nltk, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NLTK before 3.10.0 (affected versions <=3.9.4) contains an unsafe pickle deserialization vulnerability in the TransitionParser.parse() method (nltk/parse/transitionparser.py). The method calls pickle_load() with the default restricted=False, routing deserialization through WarningUnpickler, which does not override find_class() and therefore permits arbitrary class resolution. When an application loads an attacker-crafted model file, embedded pickle gadget chains execute arbitrary Python code with the privileges of the user running the application. NLTK provides a RestrictedUnpickler for safe deserialization, but it is not used by production code paths. Fixed in 3.10.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-78683?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |

Products: Nltk Nltk.

## How do I fix CVE-2026-78683?

Upgrade nltk to 3.10.0 or later.

## Is CVE-2026-78683 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78683 exists.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)
- [CVE-2026-79674](https://insights.sbomify.com/CVE-2026-79674/): NLTK 3.10.2 Path Traversal via corpus-reader constructors (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78683 and fix it if it is affected.

What it is: CVE-2026-78683 is a critical unsafe deserialization vulnerability in nltk, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78683 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78683/ (Markdown: https://insights.sbomify.com/CVE-2026-78683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78683
- OSV: https://osv.dev/vulnerability/CVE-2026-78683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78683/
Summaries are generated and may contain mistakes; the official description above is the record.
