# CVE-2026-7873: Code Injection Vulnerability in Code Validation Endpoint

> Authenticated attackers can execute arbitrary OS commands and read sensitive files in IBM Langflow OSS, leading to system compromise.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 1 Jul 2026
- **Also known as:** GHSA-v798-mcc6-2m3m

## What is CVE-2026-7873?

CVE-2026-7873 is a critical code injection vulnerability in Langflow Langflow, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated attackers to execute arbitrary OS commands and read sensitive files including credentials, enabling complete system compromise and lateral movement.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-7873?

2 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.0.0 | 1.10.1.rc0 |
| `langflow` | PyPI | From 1.0.0 | 1.10.1.rc0 |

Products: Langflow Langflow.

## How do I fix CVE-2026-7873?

Upgrade langflow to 1.10.1.rc0 or later.

## Is CVE-2026-7873 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7873 exists.

Public exploit code:

- PoC exploit code for CVE-2026-7873 (github_poc): https://github.com/rmhowe425/POC-CVE-2026-7873
- Langflow AI Code Validation Authenticated RCE (metasploit)

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7873 and fix it if it is affected.

What it is: CVE-2026-7873 is a critical code injection vulnerability in Langflow Langflow, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7873 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.0.0; fixed in 1.10.1.rc0
- langflow (PyPI): affected from 1.0.0; fixed in 1.10.1.rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7873/ (Markdown: https://insights.sbomify.com/CVE-2026-7873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7873
- OSV: https://osv.dev/vulnerability/CVE-2026-7873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7873/
Summaries are generated and may contain mistakes; the official description above is the record.
