# CVE-2026-78863: liketrek TREK Pre-2FA mfa_token authService.ts loginUser improper authentication

> Remote attackers can bypass authentication in the Pre-2FA mfa_token handler, potentially taking over user accounts.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-mjh4-w6fq-54qm, GHSA-x6rr-9jxr-vqvg

## What is CVE-2026-78863?

CVE-2026-78863 is a medium-severity authentication bypass vulnerability in liketrek TREK, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in liketrek TREK up to 3.0.22. Impacted is the function loginUser of the file server/src/services/authService.ts of the component Pre-2FA mfa_token Handler. The manipulation results in improper authentication. The attack may be performed from remote. Upgrading to version 3.1.0 is recommended to address this issue. Upgrading the affected component is recommended.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-78863?


## How do I fix CVE-2026-78863?

No fix has been published for CVE-2026-78863 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-78863 being exploited?

There is no known exploitation of CVE-2026-78863 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78863 and fix it if it is affected.

What it is: CVE-2026-78863 is a medium-severity authentication bypass vulnerability in liketrek TREK, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-78863 in the wild and no public exploit code.

Affected product: liketrek TREK. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78863/ (Markdown: https://insights.sbomify.com/CVE-2026-78863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78863
- OSV: https://osv.dev/vulnerability/CVE-2026-78863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78863/
Summaries are generated and may contain mistakes; the official description above is the record.
