{"answers":{"affected":"2 open source packages ship an affected version, including concrete5/concrete5.","exploited":"There is no known exploitation of CVE-2026-7888 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to 9.5.2 or later.","what":"CVE-2026-7888 is a high-severity unsafe deserialization vulnerability in Concrete CMS, published on 3 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7888 and fix it if it is affected.\n\nWhat it is: CVE-2026-7888 is a high-severity unsafe deserialization vulnerability in Concrete CMS, published on 3 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-7888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.2\n- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7888/ (Markdown: https://insights.sbomify.com/CVE-2026-7888/index.md)","id":"CVE-2026-7888","markdown":"https://insights.sbomify.com/CVE-2026-7888/index.md","name":"CVE-2026-7888","record":{"aliases":["GHSA-52pr-7vmf-2w7x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Concrete CMS","requires_auth":"high_privilege","summary":"Unauthenticated attackers can trigger arbitrary PHP object instantiation via unsafe deserialization in Concrete CMS components.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"ConcreteCMS","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Concrete CMS below 9.5.3 is vulnerable to PHP Object Injection via unserialize()\ncalls in the Workflow, Form block, and File/Set components that lack the\nallowed_classes restriction. The Form block and File/Set sinks were addressed in\n9.5.2; the Workflow component sinks were addressed in 9.5.3. An unauthenticated\nattacker may trigger arbitrary PHP object instantiation if a malicious serialized\npayload has been placed in the database. Thanks XananasX7 and Sanjorn Keeratirungsan\n(dizconnect) for independently reporting the original components, and sh4d0byss for\nreporting the Workflow component wasn't fixed in 9.5.2. The Concrete CMS security team gave this\nvulnerability a CVSS v.4.0 score of 8.4 with vector CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/\nVC:H/VI:H/VA:H/SC:N/SI:N/SA:N.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concrete CMS is vulnerable to PHP Object Injection via unserialize() calls in the Workflow, Form block, and File/Set components","id":"CVE-2026-7888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Concrete CMS 9.5.0 is vulnerable to SSRF via RSS Displayer Block","id":"CVE-2026-7890"},"packages":[{"ecosystem":"Packagist","fixed":["9.5.2"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-52pr-7vmf-2w7x"},{"ecosystem":"Packagist","fixed":["9.5.2"],"introduced":["0"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-52pr-7vmf-2w7x"}],"prev":{"headline":"For Concrete CMS 9.5.0 and below, OAuth 2.0 Authorization-Code Handler Bypasses Account Status","id":"CVE-2026-7887"},"products":["Concrete CMS"],"published":"2026-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-11","vendors":["Concrete CMS"]},"summary":"Unauthenticated attackers can trigger arbitrary PHP object instantiation via unsafe deserialization in Concrete CMS components.","url":"https://insights.sbomify.com/CVE-2026-7888/"}