CVE-2026-7890 Concrete CMS 9.5.0 is vulnerable to SSRF via RSS Displayer Block

Low 2.1 Published Updated

Attackers with editor privileges can exploit the RSS Displayer block to perform server-side request forgery, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-7890?

CVE-2026-7890 is a low-severity server-side request forgery vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In Concrete CMS 9.5.0 and below, the RSS Displayer block accepts a feed URL from any page editor and fetches it server-side without validation enabling redirect-to-internal bypasses.  The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.1 with a vector CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:N/SA:N.

Weakness: CWE-918

Which versions are affected by CVE-2026-7890?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions9.5.1
concrete5/concrete5 PackagistAll versions9.5.1

Products include Concretecms Concrete Cms.

How do I fix CVE-2026-7890?

Upgrade concrete5/concrete5 to 9.5.1 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-7890 being exploited?

There is no known exploitation of CVE-2026-7890 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-gjwq-9v8p-47w7.

Is CVE-2026-7890 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free