# CVE-2026-7890: Concrete CMS 9.5.0 is vulnerable to SSRF via RSS Displayer Block

> Attackers with editor privileges can exploit the RSS Displayer block to perform server-side request forgery, potentially accessing internal resources.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-gjwq-9v8p-47w7

## What is CVE-2026-7890?

CVE-2026-7890 is a low-severity server-side request forgery vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Concrete CMS 9.5.0 and below, the RSS Displayer block accepts a feed URL from any page editor and fetches it server-side without validation enabling redirect-to-internal bypasses.  The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.1 with a vector CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:N/SA:N.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-7890?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2026-7890?

Upgrade concrete5/concrete5 to 9.5.1 or later.

## Is CVE-2026-7890 being exploited?

There is no known exploitation of CVE-2026-7890 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7890 and fix it if it is affected.

What it is: CVE-2026-7890 is a low-severity server-side request forgery vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7890 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7890/ (Markdown: https://insights.sbomify.com/CVE-2026-7890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7890
- OSV: https://osv.dev/vulnerability/CVE-2026-7890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7890/
Summaries are generated and may contain mistakes; the official description above is the record.
