# CVE-2026-79659: Ech0 before 4.7.3 Server-Side Request Forgery via fetchPeerConnectInfo

> Authenticated attackers can exploit Ech0 to access internal services and cloud metadata via unvalidated URLs in peer connection operations.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-8mc6-xjpr-h98x, GHSA-9g26-825h-8v6p, GO-2026-5259

## What is CVE-2026-79659?

CVE-2026-79659 is a high-severity server-side request forgery vulnerability in lin-snow Ech0, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ech0 before 4.7.3 contains a server-side request forgery vulnerability in the fetchPeerConnectInfo function that uses unvalidated HTTP requests instead of safe request methods with URL validation. Authenticated attackers can supply arbitrary URLs to access internal services and cloud metadata endpoints by triggering connection health checks or peer connection operations.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-79659?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040602-091d26d2d942 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040602-091d26d2d942 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040602-091d26d2d942 |

## How do I fix CVE-2026-79659?

Upgrade github.com/lin-snow/ech0 to 1.4.8-0.20260503040602-091d26d2d942 or later.

## Is CVE-2026-79659 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79659 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79659 and fix it if it is affected.

What it is: CVE-2026-79659 is a high-severity server-side request forgery vulnerability in lin-snow Ech0, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79659 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040602-091d26d2d942
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040602-091d26d2d942
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040602-091d26d2d942

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79659/ (Markdown: https://insights.sbomify.com/CVE-2026-79659/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79659
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79659
- OSV: https://osv.dev/vulnerability/CVE-2026-79659

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79659/
Summaries are generated and may contain mistakes; the official description above is the record.
