# CVE-2026-79660: Ech0 before 4.7.3 Email Disclosure via Public API

> Unauthenticated attackers can harvest guest commenter email addresses via public API endpoints in Ech0 due to improper JSON serialization.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-845p-52xj-2432, GHSA-rj4g-rqgh-rx9h, GO-2026-5626

## What is CVE-2026-79660?

CVE-2026-79660 is a medium-severity vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ech0 versions before 4.7.3 expose guest commenter email addresses through public API endpoints due to improper JSON serialization tags on the Comment model. Unauthenticated attackers can harvest all commenter emails by calling the /api/comments and /api/comments/public endpoints without authentication.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-79660?

3 open source packages ship an affected version, including github.com/lin-snow/Ech0 and github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/Ech0` | Go | All versions | 1.4.8-0.20260503034700-cb8d7a997dd8 |
| `github.com/lin-snow/Ech0` | Go | All versions | 1.4.8-0.20260503034700-cb8d7a997dd8 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503034700-cb8d7a997dd8 |

## How do I fix CVE-2026-79660?

Upgrade github.com/lin-snow/Ech0 to 1.4.8-0.20260503034700-cb8d7a997dd8 or later.

## Is CVE-2026-79660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79660 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79660 and fix it if it is affected.

What it is: CVE-2026-79660 is a medium-severity vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79660 exists.

Affected packages and fixed versions:
- github.com/lin-snow/Ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503034700-cb8d7a997dd8
- github.com/lin-snow/Ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503034700-cb8d7a997dd8
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503034700-cb8d7a997dd8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79660/ (Markdown: https://insights.sbomify.com/CVE-2026-79660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79660
- OSV: https://osv.dev/vulnerability/CVE-2026-79660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79660/
Summaries are generated and may contain mistakes; the official description above is the record.
