# CVE-2026-79664: Ech0 before 4.7.3 Access Token Revocation Bypass

> Attackers with stolen never-expire tokens maintain perpetual access because Ech0 fails to revoke them via logout, API, or admin actions.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3r5q-vfpj-wprr, GHSA-fpw6-hrg5-q5x5, GO-2026-5375

## What is CVE-2026-79664?

CVE-2026-79664 is a critical vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ech0 before 4.7.3 fails to properly revoke access tokens created with never-expire option, allowing attackers to maintain perpetual authenticated access after token theft. Three independent revocation mechanisms fail: logout panics on nil ExpiresAt field, RevokeToken skips when remainTTL is zero, and admin delete does not blacklist the JTI, leaving stolen tokens cryptographically valid until JWT secret rotation.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-79664?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503041146-eab62379c795 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503041146-eab62379c795 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503041146-eab62379c795 |

## How do I fix CVE-2026-79664?

Upgrade github.com/lin-snow/ech0 to 1.4.8-0.20260503041146-eab62379c795 or later.

## Is CVE-2026-79664 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79664 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79664 and fix it if it is affected.

What it is: CVE-2026-79664 is a critical vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79664 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503041146-eab62379c795
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503041146-eab62379c795
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503041146-eab62379c795

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79664/ (Markdown: https://insights.sbomify.com/CVE-2026-79664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79664
- OSV: https://osv.dev/vulnerability/CVE-2026-79664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79664/
Summaries are generated and may contain mistakes; the official description above is the record.
