CVE-2026-79667 Ech0 before 4.4.3 Authentication Bypass via Scope Enforcement
Attackers with low-scope admin tokens can bypass scope restrictions to access privileged endpoints and export full database backups.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-79667?
CVE-2026-79667 is a high-severity authentication bypass vulnerability in lin-snow Ech0, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Ech0 version 4.3.4 and earlier fails to reliably enforce scoped access token (least-privilege) restrictions on several privileged admin routes. Multiple privileged endpoints (e.g., /api/inbox, /api/panel/comments, /api/backup/export) omit scope checks and authorize based only on the user's admin role, and the backup export handler discards token scope metadata entirely. An attacker holding a deliberately limited (low-scope) admin access token can reach broader privileged functionality than intended, including reading the inbox and exporting a full database backup ZIP archive. Fixed in 4.4.3.
Weakness: CWE-285
Which versions are affected by CVE-2026-79667?
3 open source packages ship an affected version, including github.com/lin-snow/ech0.
| Package | Affected | Fixed in |
|---|---|---|
github.com/lin-snow/ech0 Go | All versions | None |
github.com/lin-snow/ech0 Go | All versions | 4.3.5 |
github.com/lin-snow/ech0 Go | All versions | 4.3.5 |
How do I fix CVE-2026-79667?
Upgrade github.com/lin-snow/ech0 to 4.3.5 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-79667 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79667 exists.
Sources
Also known as GHSA-4h9q-p5j4-xvvh, GHSA-vgpj-v99m-7h5j, GO-2026-5123.