# CVE-2026-79667: Ech0 before 4.4.3 Authentication Bypass via Scope Enforcement

> Attackers with low-scope admin tokens can bypass scope restrictions to access privileged endpoints and export full database backups.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-4h9q-p5j4-xvvh, GHSA-vgpj-v99m-7h5j, GO-2026-5123

## What is CVE-2026-79667?

CVE-2026-79667 is a high-severity authentication bypass vulnerability in lin-snow Ech0, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ech0 version 4.3.4 and earlier fails to reliably enforce scoped access token (least-privilege) restrictions on several privileged admin routes. Multiple privileged endpoints (e.g., /api/inbox, /api/panel/comments, /api/backup/export) omit scope checks and authorize based only on the user's admin role, and the backup export handler discards token scope metadata entirely. An attacker holding a deliberately limited (low-scope) admin access token can reach broader privileged functionality than intended, including reading the inbox and exporting a full database backup ZIP archive. Fixed in 4.4.3.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-79667?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | None |
| `github.com/lin-snow/ech0` | Go | All versions | 4.3.5 |
| `github.com/lin-snow/ech0` | Go | All versions | 4.3.5 |

## How do I fix CVE-2026-79667?

Upgrade github.com/lin-snow/ech0 to 4.3.5 or later.

## Is CVE-2026-79667 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79667 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79667 and fix it if it is affected.

What it is: CVE-2026-79667 is a high-severity authentication bypass vulnerability in lin-snow Ech0, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79667 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; no fix listed
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.3.5
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79667/ (Markdown: https://insights.sbomify.com/CVE-2026-79667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79667
- OSV: https://osv.dev/vulnerability/CVE-2026-79667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79667/
Summaries are generated and may contain mistakes; the official description above is the record.
