# CVE-2026-79668: Ech0 before 4.7.3 Unauthenticated Like Endpoint Metric Inflation

> Unauthenticated attackers can inflate engagement metrics on Ech0 by repeatedly calling the like endpoint without identity verification.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-7v7f-8gw6-2q2x, GHSA-rgj7-vg8v-j4wr, GO-2026-5623

## What is CVE-2026-79668?

CVE-2026-79668 is a medium-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ech0 before 4.7.3 contains an authentication bypass vulnerability in the PUT /api/echo/like/:id endpoint that allows unauthenticated attackers to increment engagement metrics without identity verification or rate limiting. Attackers can send repeated requests to arbitrarily inflate the fav_count field for any known echo identifier, compromising the integrity of engagement metrics and social ranking systems.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-79668?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040728-a7e8b8e84bd1 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040728-a7e8b8e84bd1 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260503040728-a7e8b8e84bd1 |

## How do I fix CVE-2026-79668?

Upgrade github.com/lin-snow/ech0 to 1.4.8-0.20260503040728-a7e8b8e84bd1 or later.

## Is CVE-2026-79668 being exploited?

There is no known exploitation of CVE-2026-79668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79668 and fix it if it is affected.

What it is: CVE-2026-79668 is a medium-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79668 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040728-a7e8b8e84bd1
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040728-a7e8b8e84bd1
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260503040728-a7e8b8e84bd1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79668/ (Markdown: https://insights.sbomify.com/CVE-2026-79668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79668
- OSV: https://osv.dev/vulnerability/CVE-2026-79668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79668/
Summaries are generated and may contain mistakes; the official description above is the record.
