# CVE-2026-79670: Ech0 before 4.4.3 Stored XSS via SVG Upload

> Admins can upload malicious SVG files causing stored XSS, allowing session hijacking and data exfiltration for any user.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-69hx-63pv-f8f4, GHSA-mj42-9vh2-f8v3, GO-2026-5172

## What is CVE-2026-79670?

CVE-2026-79670 is a medium-severity cross-site scripting vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Ech0 before 4.4.3 contains a stored cross-site scripting vulnerability in the file upload endpoint that validates Content-Type using only client-supplied headers without server-side inspection. Attackers with admin privileges can upload SVG or HTML files containing JavaScript that executes in the application origin when accessed by any user, enabling session hijacking and data exfiltration.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-79670?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | None |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |

## How do I fix CVE-2026-79670?

Upgrade github.com/lin-snow/ech0 to 4.4.3 or later.

## Is CVE-2026-79670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79670 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79670 and fix it if it is affected.

What it is: CVE-2026-79670 is a medium-severity cross-site scripting vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79670 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; no fix listed
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79670/ (Markdown: https://insights.sbomify.com/CVE-2026-79670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79670
- OSV: https://osv.dev/vulnerability/CVE-2026-79670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79670/
Summaries are generated and may contain mistakes; the official description above is the record.
