# CVE-2026-79671: Ech0 before 4.4.3 SSRF via DNS Resolution Bypass

> An attacker with admin privileges can bypass webhook URL validation to access internal services and cloud metadata endpoints via SSRF.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** GHSA-7rwv-fqq2-88c4, GHSA-r2x7-427f-rq69, GO-2026-5603

## What is CVE-2026-79671?

CVE-2026-79671 is a medium-severity server-side request forgery vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ech0 before 4.4.3 contains a server-side request forgery vulnerability in the validateWebhookURL function (webhook_setting_service.go), which only validates literal IP addresses via net.ParseIP() and fails to reject hostnames that DNS-resolve to private or internal IPs (e.g., 169.254.169.254.nip.io). An attacker with admin privileges can create a webhook with such a hostname to bypass validation and cause the server to make requests to internal services, cloud metadata endpoints, and private network resources. The issue is fixed in 4.4.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-79671?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | None |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |

## How do I fix CVE-2026-79671?

Upgrade github.com/lin-snow/ech0 to 4.4.3 or later.

## Is CVE-2026-79671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79671 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79671 and fix it if it is affected.

What it is: CVE-2026-79671 is a medium-severity server-side request forgery vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79671 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; no fix listed
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79671/ (Markdown: https://insights.sbomify.com/CVE-2026-79671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79671
- OSV: https://osv.dev/vulnerability/CVE-2026-79671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79671/
Summaries are generated and may contain mistakes; the official description above is the record.
