# CVE-2026-79672: Ech0 before 4.4.3 Authentication Bypass via Comment Panel

> Attackers with limited-scope tokens can bypass authorization to perform full comment moderation and modify settings in Ech0.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-fwg7-53p4-g33c, GHSA-x98j-gh4v-7p7g, GO-2026-5382

## What is CVE-2026-79672?

CVE-2026-79672 is a high-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ech0 before 4.4.3 fails to enforce scope-based authorization on nine comment panel admin endpoints, allowing access tokens with minimal scopes to perform full comment moderation operations. Attackers with a limited-scope access token can list, approve, reject, delete comments, and modify comment system settings by directly accessing the unprotected panel endpoints.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-79672?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | None |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |

## How do I fix CVE-2026-79672?

Upgrade github.com/lin-snow/ech0 to 4.4.3 or later.

## Is CVE-2026-79672 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79672 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79672 and fix it if it is affected.

What it is: CVE-2026-79672 is a high-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79672 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; no fix listed
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79672/ (Markdown: https://insights.sbomify.com/CVE-2026-79672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79672
- OSV: https://osv.dev/vulnerability/CVE-2026-79672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79672/
Summaries are generated and may contain mistakes; the official description above is the record.
