# CVE-2026-79673: Ech0 before 4.4.3 Scope Bypass via profile:read Token

> Attackers with read-only tokens can modify admin passwords, leading to full account takeover and bypassing scope restrictions.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-6h3p-88p7-m8gp, GHSA-hm2h-wwwh-g49x, GO-2026-5431

## What is CVE-2026-79673?

CVE-2026-79673 is a high-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Ech0 before 4.4.3 protects the PUT /user endpoint with the profile:read scope, a read-only scope, but allows write operations including password changes. An attacker with an admin's profile:read access token can change the admin's password and login to obtain an unrestricted session token that bypasses all scope enforcement.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-79673?

3 open source packages ship an affected version, including github.com/lin-snow/ech0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | None |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |
| `github.com/lin-snow/ech0` | Go | All versions | 4.4.3 |

## How do I fix CVE-2026-79673?

Upgrade github.com/lin-snow/ech0 to 4.4.3 or later.

## Is CVE-2026-79673 being exploited?

There is no known exploitation of CVE-2026-79673 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79673 and fix it if it is affected.

What it is: CVE-2026-79673 is a high-severity missing authorization vulnerability in lin-snow Ech0, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79673 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; no fix listed
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79673/ (Markdown: https://insights.sbomify.com/CVE-2026-79673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79673
- OSV: https://osv.dev/vulnerability/CVE-2026-79673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79673/
Summaries are generated and may contain mistakes; the official description above is the record.
