# CVE-2026-79677: Apache Tomcat: WebSocket DoS due to lost asynchronous write timeout

> Apache Tomcat suffers from a denial of service vulnerability due to lost asynchronous write timeouts in WebSocket connections.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** BIT-tomcat-2026-79677, DEBIAN-CVE-2026-79677, GHSA-r5gx-4gq8-822g, MINI-hgpm-j82r-g9xf, MINI-m754-5mr9-hfvh, MINI-mppw-6c2q-x35h, UBUNTU-CVE-2026-79677

## What is CVE-2026-79677?

CVE-2026-79677 is a high-severity denial of service vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing release of resource after effective lifetime, Comparison using wrong factors vulnerability in Apache Tomcat allows a denial of service as a result of lost time outs for asynchronous WebSocket writes.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime), CWE-1025 (Comparison Using Wrong Factors)

## Which versions are affected by CVE-2026-79677?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | All versions | 9.0.45, 10.1.60, 11.0.26, 9.0.122 |

## How do I fix CVE-2026-79677?

Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.

## Is CVE-2026-79677 being exploited?

There is no known exploitation of CVE-2026-79677 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79677 and fix it if it is affected.

What it is: CVE-2026-79677 is a high-severity denial of service vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79677 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected all versions; fixed in 9.0.45, 10.1.60, 11.0.26, 9.0.122

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79677/ (Markdown: https://insights.sbomify.com/CVE-2026-79677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79677
- OSV: https://osv.dev/vulnerability/CVE-2026-79677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79677/
Summaries are generated and may contain mistakes; the official description above is the record.
