CVE-2026-79708 Incorrect Authorization in GitLab

High 8.5 Published Updated

Authenticated developers can bypass scope validation to execute policy tests and access protected CI/CD variables intended for higher-privileged roles.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-79708?

CVE-2026-79708 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions could have allowed an authenticated user with developer permissions to execute a policy test pipeline on projects within their group and access protected CI/CD variables restricted to higher-privileged roles, due to insufficient scope validation.

Weakness: CWE-863

Which versions are affected by CVE-2026-79708?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 19.0.019.1.8, 19.2.6, 19.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-79708?

Upgrade gitlab to a fixed version for your release line: 19.1.8, 19.2.6 or 19.3.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-79708 being exploited?

There is no known exploitation of CVE-2026-79708 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-79708, GHSA-4gg6-pm69-gwm2, MINI-c3r2-mg97-xg7c, MINI-p4c3-pcqv-h2x6, MINI-vwmc-9r3h-v2vh.

Is CVE-2026-79708 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free