# CVE-2026-79708: Incorrect Authorization in GitLab

> Authenticated developers can bypass scope validation to execute policy tests and access protected CI/CD variables intended for higher-privileged roles.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-gitlab-2026-79708, GHSA-4gg6-pm69-gwm2, MINI-c3r2-mg97-xg7c, MINI-p4c3-pcqv-h2x6, MINI-vwmc-9r3h-v2vh

## What is CVE-2026-79708?

CVE-2026-79708 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions could have allowed an authenticated user with developer permissions to execute a policy test pipeline on projects within their group and access protected CI/CD variables restricted to higher-privileged roles, due to insufficient scope validation.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-79708?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 19.0.0 | 19.1.8, 19.2.6, 19.3.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-79708?

Upgrade gitlab to a fixed version for your release line: 19.1.8, 19.2.6 or 19.3.2.

## Is CVE-2026-79708 being exploited?

There is no known exploitation of CVE-2026-79708 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79708 and fix it if it is affected.

What it is: CVE-2026-79708 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79708 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 19.0.0; fixed in 19.1.8, 19.2.6, 19.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79708/ (Markdown: https://insights.sbomify.com/CVE-2026-79708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79708
- OSV: https://osv.dev/vulnerability/CVE-2026-79708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79708/
Summaries are generated and may contain mistakes; the official description above is the record.
