# CVE-2026-79719: Cross-site scripting in Netron

> Reflected XSS in Netron allows attackers to hide nodes, scan ports, or achieve remote code execution via unsanitized node names.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-wfq7-j297-j875, PYSEC-2026-4002

## What is CVE-2026-79719?

CVE-2026-79719 is a medium-severity cross-site scripting vulnerability in Netron, published on 27 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Reflected XSS in Netron versions <=9.1.2 on desktop application through unsanitized node names allows an attacker to hide certain nodes, perform port scanning or abuse a Chrome n-day to achieve Remote Code Execution.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-79719?

1 open source package ship an affected version, including netron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `netron` | PyPI | All versions | 9.1.3 |

Products: Lutzroeder Netron.

## How do I fix CVE-2026-79719?

Upgrade netron to 9.1.3 or later.

## Is CVE-2026-79719 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79719 exists.

## Other vulnerabilities in Netron

- [CVE-2026-79718](https://insights.sbomify.com/CVE-2026-79718/): Cross-site scripting in Netron (medium 6.8)
- [CVE-2026-79720](https://insights.sbomify.com/CVE-2026-79720/): Cross-site scripting in Netron (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79719 and fix it if it is affected.

What it is: CVE-2026-79719 is a medium-severity cross-site scripting vulnerability in Netron, published on 27 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79719 exists.

Affected packages and fixed versions:
- netron (PyPI): affected all versions; fixed in 9.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79719/ (Markdown: https://insights.sbomify.com/CVE-2026-79719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79719
- OSV: https://osv.dev/vulnerability/CVE-2026-79719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79719/
Summaries are generated and may contain mistakes; the official description above is the record.
