CVE-2026-79752 CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection
Attackers can execute arbitrary SQL commands via unescaped parameters in CakePHP FunctionsBuilder methods, compromising database confidentiality, integrity, and availability.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-79752?
CVE-2026-79752 is a critical SQL injection vulnerability in cakephp, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CakePHP is a rapid development framework for PHP. Prior to 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7, FunctionsBuilder::cast, FunctionsBuilder::extract, FunctionsBuilder::datePart, and FunctionsBuilder::dateAdd in src/Database/FunctionsBuilder.php accept user-controlled dataType, part, or unit values and incorporate them into generated SQL as unescaped structural fragments. An application that passes untrusted input to these parameters can permit SQL injection with confidentiality, integrity, and availability impact according to the database connection's privileges. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7.
Weakness: CWE-89
Which versions are affected by CVE-2026-79752?
20 open source packages ship an affected version, including cakephp/cakephp and cakephp/database.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | All versions | 4.5.12 |
cakephp/cakephp Packagist | All versions | 4.5.12 |
cakephp/cakephp Packagist | From 4.6.0 | 4.6.5 |
cakephp/cakephp Packagist | From 4.6.0 | 4.6.5 |
cakephp/cakephp Packagist | From 5.0.0 | 5.1.9 |
cakephp/cakephp Packagist | From 5.0.0 | 5.1.9 |
14 more packages
cakephp/cakephp Packagist | From 5.2.0 | 5.2.14 |
cakephp/cakephp Packagist | From 5.2.0 | 5.2.14 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
cakephp/database Packagist | From 3.0.0 | 4.5.12 |
cakephp/database Packagist | From 3.0.0 | 4.5.12 |
cakephp/database Packagist | From 4.6.0 | 4.6.5 |
cakephp/database Packagist | From 4.6.0 | 4.6.5 |
cakephp/database Packagist | From 5.0.0 | 5.1.9 |
cakephp/database Packagist | From 5.0.0 | 5.1.9 |
cakephp/database Packagist | From 5.2.0 | 5.2.14 |
cakephp/database Packagist | From 5.2.0 | 5.2.14 |
cakephp/database Packagist | From 5.3.0 | 5.3.7 |
cakephp/database Packagist | From 5.3.0 | 5.3.7 |
How do I fix CVE-2026-79752?
Upgrade cakephp/cakephp to a fixed version for your release line: 4.5.12, 4.6.5, 5.1.9 or 5.2.14.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-79752 being exploited?
There is no known exploitation of CVE-2026-79752 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-vjqc-q4mp-2rvf, UBUNTU-CVE-2026-79752.