# CVE-2026-79752: CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection

> Attackers can execute arbitrary SQL commands via unescaped parameters in CakePHP FunctionsBuilder methods, compromising database confidentiality, integrity, and availability.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-vjqc-q4mp-2rvf, UBUNTU-CVE-2026-79752

## What is CVE-2026-79752?

CVE-2026-79752 is a critical SQL injection vulnerability in cakephp, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CakePHP is a rapid development framework for PHP. Prior to 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7, FunctionsBuilder::cast, FunctionsBuilder::extract, FunctionsBuilder::datePart, and FunctionsBuilder::dateAdd in src/Database/FunctionsBuilder.php accept user-controlled dataType, part, or unit values and incorporate them into generated SQL as unescaped structural fragments. An application that passes untrusted input to these parameters can permit SQL injection with confidentiality, integrity, and availability impact according to the database connection's privileges. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-79752?

20 open source packages ship an affected version, including cakephp/cakephp and cakephp/database.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/cakephp` | Packagist | All versions | 4.5.12 |
| `cakephp/cakephp` | Packagist | All versions | 4.5.12 |
| `cakephp/cakephp` | Packagist | From 4.6.0 | 4.6.5 |
| `cakephp/cakephp` | Packagist | From 4.6.0 | 4.6.5 |
| `cakephp/cakephp` | Packagist | From 5.0.0 | 5.1.9 |
| `cakephp/cakephp` | Packagist | From 5.0.0 | 5.1.9 |
| `cakephp/cakephp` | Packagist | From 5.2.0 | 5.2.14 |
| `cakephp/cakephp` | Packagist | From 5.2.0 | 5.2.14 |
| `cakephp/cakephp` | Packagist | From 5.3.0 | 5.3.7 |
| `cakephp/cakephp` | Packagist | From 5.3.0 | 5.3.7 |
| `cakephp/database` | Packagist | From 3.0.0 | 4.5.12 |
| `cakephp/database` | Packagist | From 3.0.0 | 4.5.12 |
| `cakephp/database` | Packagist | From 4.6.0 | 4.6.5 |
| `cakephp/database` | Packagist | From 4.6.0 | 4.6.5 |
| `cakephp/database` | Packagist | From 5.0.0 | 5.1.9 |
| `cakephp/database` | Packagist | From 5.0.0 | 5.1.9 |
| `cakephp/database` | Packagist | From 5.2.0 | 5.2.14 |
| `cakephp/database` | Packagist | From 5.2.0 | 5.2.14 |
| `cakephp/database` | Packagist | From 5.3.0 | 5.3.7 |
| `cakephp/database` | Packagist | From 5.3.0 | 5.3.7 |

## How do I fix CVE-2026-79752?

Upgrade cakephp/cakephp to a fixed version for your release line: 4.5.12, 4.6.5, 5.1.9 or 5.2.14.

## Is CVE-2026-79752 being exploited?

There is no known exploitation of CVE-2026-79752 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-79752 - CakePHP - Critical 9.2 - Unauthenticated GET /?type= - SQL Injection (github_poc): https://github.com/abraxas/CVE-2026-79752

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79752 and fix it if it is affected.

What it is: CVE-2026-79752 is a critical SQL injection vulnerability in cakephp, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79752 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/cakephp (Packagist): affected all versions; fixed in 4.5.12
- cakephp/cakephp (Packagist): affected all versions; fixed in 4.5.12
- cakephp/cakephp (Packagist): affected from 4.6.0; fixed in 4.6.5
- cakephp/cakephp (Packagist): affected from 4.6.0; fixed in 4.6.5
- cakephp/cakephp (Packagist): affected from 5.0.0; fixed in 5.1.9
- cakephp/cakephp (Packagist): affected from 5.0.0; fixed in 5.1.9
- cakephp/cakephp (Packagist): affected from 5.2.0; fixed in 5.2.14
- cakephp/cakephp (Packagist): affected from 5.2.0; fixed in 5.2.14
- cakephp/cakephp (Packagist): affected from 5.3.0; fixed in 5.3.7
- cakephp/cakephp (Packagist): affected from 5.3.0; fixed in 5.3.7
- cakephp/database (Packagist): affected from 3.0.0; fixed in 4.5.12
- cakephp/database (Packagist): affected from 3.0.0; fixed in 4.5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79752/ (Markdown: https://insights.sbomify.com/CVE-2026-79752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79752
- OSV: https://osv.dev/vulnerability/CVE-2026-79752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79752/
Summaries are generated and may contain mistakes; the official description above is the record.
