CVE-2026-79767 Gardener: Authorization Bypass via Group Subject Injection
A project administrator can bypass authorization checks to add unauthorized group subjects, gaining broad access to sensitive cluster resources and credentials.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-79767?
CVE-2026-79767 is a medium-severity authentication bypass vulnerability in gardener, published on 22 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Gardener implements the automated management and operation of Kubernetes clusters as a service. Prior to 1.142.6, 1.143.3, 1.144.2, and 1.145.0, the customverbauthorizer admission plugin's mustCheckProjectMembers manage-members check compares changes to User subjects but does not account for Group or ServiceAccount subjects in Project.spec.members. A project administrator who lacks manage-members permission can add arbitrary Group or ServiceAccount subjects, including the system:authenticated Group, and thereby grant broad project access. The resulting access can include Shoots, Secrets, and cloud provider credentials. This issue is fixed in versions 1.142.6, 1.143.3, 1.144.2, and 1.145.0.
Weakness: CWE-863
Which versions are affected by CVE-2026-79767?
8 open source packages ship an affected version, including gardener/gardener and github.com/gardener/gardener.
| Package | Affected | Fixed in |
|---|---|---|
gardener/gardener Go | From 1.143.0 | 1.143.3 |
gardener/gardener Go | From 1.143.0 | 1.143.3 |
gardener/gardener Go | From 1.144.0 | 1.144.2 |
gardener/gardener Go | From 1.144.0 | 1.144.2 |
github.com/gardener/gardener Go | All versions | None |
github.com/gardener/gardener Go | All versions | 1.142.6 |
2 more packages
github.com/gardener/gardener Go | All versions | 1.142.6 |
github.com/gardener/gardener Go | All versions | 1.142.6 |
How do I fix CVE-2026-79767?
Upgrade gardener/gardener to a fixed version for your release line: 1.143.3 or 1.144.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-79767 being exploited?
There is no known exploitation of CVE-2026-79767 in the wild and no public exploit code.
Sources
Also known as GHSA-gfjv-gqf2-c888, GO-2026-6568.