# CVE-2026-79773: Winter CMS before 1.2.13 Local File Inclusion via JavaScript

> Authenticated users with asset management permissions can read arbitrary server files, exposing sensitive credentials to unauthenticated visitors.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-2223-f22x-24cq, GHSA-gqr6-9g7c-7g7r

## What is CVE-2026-79773?

CVE-2026-79773 is a medium-severity path traversal vulnerability in wintercms winter, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Winter CMS before 1.2.13 contains a local file inclusion vulnerability in the JavascriptImporter filter that allows authenticated users with cms.manage_assets permission to disclose arbitrary server-readable files by placing =include or =require directives in theme JavaScript assets. Attackers can reference files like .env outside the theme directory, and the combined output served through the combine route becomes readable by unauthenticated visitors, exposing application keys and database credentials.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-79773?

2 open source packages ship an affected version, including winter/wn-system-module.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-system-module` | Packagist | All versions | 1.2.13 |
| `winter/wn-system-module` | Packagist | All versions | 1.2.13 |

## How do I fix CVE-2026-79773?

Upgrade winter/wn-system-module to 1.2.13 or later.

## Is CVE-2026-79773 being exploited?

There is no known exploitation of CVE-2026-79773 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79773 and fix it if it is affected.

What it is: CVE-2026-79773 is a medium-severity path traversal vulnerability in wintercms winter, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79773 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-system-module (Packagist): affected all versions; fixed in 1.2.13
- winter/wn-system-module (Packagist): affected all versions; fixed in 1.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79773/ (Markdown: https://insights.sbomify.com/CVE-2026-79773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79773
- OSV: https://osv.dev/vulnerability/CVE-2026-79773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79773/
Summaries are generated and may contain mistakes; the official description above is the record.
