# CVE-2026-79774: Winter CMS before 1.2.13 Twig Sandbox Escape via SecurityPolicy

> Authenticated users with template permissions can bypass Twig sandbox restrictions to execute arbitrary code and modify database records.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-8cfw-pcwh-v63w, GHSA-gw97-553p-fp3j

## What is CVE-2026-79774?

CVE-2026-79774 is a critical code injection vulnerability in wintercms winter, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Winter CMS versions before 1.2.13 contain an incomplete fix for a Twig sandbox escape vulnerability in System\\Twig\\SecurityPolicy that allows authenticated backend users with template-editing permissions to bypass sandbox restrictions. Attackers can exploit method forwarding through Eloquent models and query builders using methods like saveQuietly(), deleteQuietly(), increment(), decrement(), and newQuery() to read and modify arbitrary database records, execute arbitrary SQL, and achieve remote code execution by injecting PHP into template code sections.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-79774?

2 open source packages ship an affected version, including winter/wn-system-module.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-system-module` | Packagist | From 1.2.7 | 1.2.13 |
| `winter/wn-system-module` | Packagist | From 1.2.7 | 1.2.13 |

## How do I fix CVE-2026-79774?

Upgrade winter/wn-system-module to 1.2.13 or later.

## Is CVE-2026-79774 being exploited?

There is no known exploitation of CVE-2026-79774 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79774 and fix it if it is affected.

What it is: CVE-2026-79774 is a critical code injection vulnerability in wintercms winter, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-79774 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-system-module (Packagist): affected from 1.2.7; fixed in 1.2.13
- winter/wn-system-module (Packagist): affected from 1.2.7; fixed in 1.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79774/ (Markdown: https://insights.sbomify.com/CVE-2026-79774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79774
- OSV: https://osv.dev/vulnerability/CVE-2026-79774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79774/
Summaries are generated and may contain mistakes; the official description above is the record.
