# CVE-2026-79777: rclone before v1.75.0 Information Disclosure via RC API

> Attackers can trigger panics in the rclone RC API to leak sensitive internal details like file paths and memory addresses.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** BIT-rclone-2026-79777, DEBIAN-CVE-2026-79777, GHSA-7fxp-9qgr-6fxw, GHSA-gwfq-86j8-7qhv, GO-2026-6181, MINI-96qf-4chg-f6p7, MINI-9w86-5jr8-x992, MINI-c493-xf58-95q8, MINI-c4jc-g4rq-xgjm, MINI-g5r8-73px-3893, MINI-hqxh-x4pw-49xf, MINI-jmgv-344q-w4cg, MINI-jw7h-r8qq-qjqg, MINI-rj93-jgjr-qp74, MINI-v77f-p4wq-j6wj, UBUNTU-CVE-2026-79777

## What is CVE-2026-79777?

CVE-2026-79777 is a medium-severity vulnerability in rclone, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

rclone before v1.75.0 includes full Go stack traces in RC API error responses when panics occur. Attackers can trigger panics to leak internal file paths, module versions, goroutine states, and memory addresses.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-79777?

4 open source packages ship an affected version, including github.com/rclone/rclone and rclone.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rclone/rclone` | Go | All versions | 1.75.0 |
| `github.com/rclone/rclone` | Go | All versions | 1.75.0 |
| `github.com/rclone/rclone` | Go | All versions | 1.75.0 |
| `rclone` | Bitnami | All versions | 1.75.0 |

## How do I fix CVE-2026-79777?

Upgrade github.com/rclone/rclone to 1.75.0 or later.

## Is CVE-2026-79777 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79777 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79777 and fix it if it is affected.

What it is: CVE-2026-79777 is a medium-severity vulnerability in rclone, published on 25 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-79777 exists.

Affected packages and fixed versions:
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.75.0
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.75.0
- github.com/rclone/rclone (Go): affected all versions; fixed in 1.75.0
- rclone (Bitnami): affected all versions; fixed in 1.75.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79777/ (Markdown: https://insights.sbomify.com/CVE-2026-79777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79777
- OSV: https://osv.dev/vulnerability/CVE-2026-79777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79777/
Summaries are generated and may contain mistakes; the official description above is the record.
