# CVE-2026-79913: Cloudreve: SSRF guard bypass: checkIP does not decode IPv6-transition wrappers (NAT64, IPv4-compatible, 6to4) reaching internal and cloud-metadata addresses

> Authenticated users can bypass SSRF protections using IPv6 transition wrappers to access internal services and cloud metadata credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-jvh5-97xg-v99f, GO-2026-6572

## What is CVE-2026-79913?

CVE-2026-79913 is a medium-severity server-side request forgery vulnerability in cloudreve, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.18.0, the ValidateExternalURL server-side request forgery guard in pkg/request/ssrf.go passes resolved addresses to checkIP without decoding NAT64, IPv4-compatible, and 6to4 IPv4-in-IPv6 transition forms. An authenticated user with remote-download access can provide SrcUri through RemoteDownloadTask.createDownloadTask so a wrapper embedding a loopback, private, link-local, or cloud metadata IPv4 address is classified as public and fetched, exposing internal service responses and cloud instance credentials. IPv4-mapped IPv6 addresses remain blocked because Go converts that form with net.IP.To4. This issue is fixed in version 4.18.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2026-79913?

5 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v4, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260715072853-1c5cad6dec7e |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260715072853-1c5cad6dec7e |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260715072853-1c5cad6dec7e |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |

## How do I fix CVE-2026-79913?

Upgrade github.com/cloudreve/Cloudreve/v4 to 4.0.0-20260715072853-1c5cad6dec7e or later.

## Is CVE-2026-79913 being exploited?

There is no known exploitation of CVE-2026-79913 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79913 and fix it if it is affected.

What it is: CVE-2026-79913 is a medium-severity server-side request forgery vulnerability in cloudreve, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79913 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260715072853-1c5cad6dec7e
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260715072853-1c5cad6dec7e
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260715072853-1c5cad6dec7e
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79913/ (Markdown: https://insights.sbomify.com/CVE-2026-79913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79913
- OSV: https://osv.dev/vulnerability/CVE-2026-79913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79913/
Summaries are generated and may contain mistakes; the official description above is the record.
