# CVE-2026-79916: MaxKB AWS Bedrock model credential injection leads to remote code execution

> Authenticated users can inject AWS credentials to execute arbitrary commands as root via botocore credential_process.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-2324-7xjr-9qxg

## What is CVE-2026-79916?

CVE-2026-79916 is a critical command injection vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. Prior to 2.10.5-lts, authenticated workspace members can inject control characters into AWS Bedrock access_key_id and secret_access_key fields that _update_aws_credentials writes to /root/.aws/credentials without safe parsing. An attacker can append a new AWS profile containing credential_process, then select that profile during a later model-validation request so botocore executes an attacker-controlled command as root. This vulnerability is fixed in 2.10.5-lts.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-79916?


## How do I fix CVE-2026-79916?

No fix has been published for CVE-2026-79916 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-79916 being exploited?

There is no known exploitation of CVE-2026-79916 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79916 and fix it if it is affected.

What it is: CVE-2026-79916 is a critical command injection vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79916 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79916/ (Markdown: https://insights.sbomify.com/CVE-2026-79916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79916
- OSV: https://osv.dev/vulnerability/CVE-2026-79916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79916/
Summaries are generated and may contain mistakes; the official description above is the record.
