# CVE-2026-79918: MaxKB: Sandbox escape via unhooked fexecve

> Authenticated attackers can escape the sandbox by calling fexecve, bypassing subprocess restrictions in MaxKB.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-9mh9-v949-fwqh

## What is CVE-2026-79918?

CVE-2026-79918 is a medium-severity vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. Prior to version 2.10.6-lts, the ToolExecutor LD_PRELOAD sandbox hooks execve, execvpe, and execveat to prevent subprocess creation but does not hook fexecve. An authenticated attacker able to execute tool code can call fexecve to start a process outside the sandbox's intended subprocess policy. This issue is fixed in version 2.10.6-lts.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-79918?


## How do I fix CVE-2026-79918?

No fix has been published for CVE-2026-79918 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-79918 being exploited?

There is no known exploitation of CVE-2026-79918 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79918 and fix it if it is affected.

What it is: CVE-2026-79918 is a medium-severity vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79918 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79918/ (Markdown: https://insights.sbomify.com/CVE-2026-79918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79918
- OSV: https://osv.dev/vulnerability/CVE-2026-79918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79918/
Summaries are generated and may contain mistakes; the official description above is the record.
