# CVE-2026-79919: Security feature bypass in MaxKB

> Authenticated users can bypass the sandbox to execute code, read/write files, and access networks by exploiting importlib callbacks and dlsym hooks.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-6h35-c779-4v37

## What is CVE-2026-79919?

CVE-2026-79919 is a medium-severity vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. Prior to version 2.10.6-lts, function-library code running under the LD_PRELOAD sandbox can invoke ctypes.CDLL from an importlib.abc.MetaPathFinder callback so the dlopen call-stack heuristic sees a Python import frame, then use unhooked dlsym with RTLD_NEXT to resolve glibc's real syscall and bypass the sandbox syscall blacklist. An authenticated workspace member can consequently read or write files, execute processes, or access networks as the sandbox user. This issue is fixed in version 2.10.6-lts.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-79919?


## How do I fix CVE-2026-79919?

No fix has been published for CVE-2026-79919 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-79919 being exploited?

There is no known exploitation of CVE-2026-79919 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79919 and fix it if it is affected.

What it is: CVE-2026-79919 is a medium-severity vulnerability in 1Panel-dev MaxKB, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79919 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79919/ (Markdown: https://insights.sbomify.com/CVE-2026-79919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79919
- OSV: https://osv.dev/vulnerability/CVE-2026-79919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79919/
Summaries are generated and may contain mistakes; the official description above is the record.
