CVE-2026-79993 Missing authorization in Apache ZooKeeper
An unauthenticated attacker can delete any empty persistent znode in Apache ZooKeeper by bypassing ACL checks on the deleteContainer opcode.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-79993?
CVE-2026-79993 is a high-severity missing authorization vulnerability in Apache ZooKeeper, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The `deleteContainer` opcode (0x14/20) is processed without verifying the caller's ACL permissions, allowing any authenticated client to delete specific znodes in the data tree regardless of the ACL restrictions on the znode or its parent. This opcode is considered internal-only and the official client doesn't have API for it, but a client that can open a plain TCP session on the ZooKeeper client port (2181 by default) - with NO authentication and NO ACL permissions - can delete any empty persistent znode (including regular persistent nodes, container nodes, and TTL nodes) by issuing the raw protocol OpCode deleteContainer (20). The deleteContainer request path completely skips both the session check and the DELETE ACL check that are enforced by the regular delete (OpCode 2) path. This is an authorization bypass / ACL enforcement bug.
This issue affects Apache ZooKeeper: from 3.9.0 through 3.9.5, from 3.8.0 through 3.8.6.
Users are recommended to upgrade to version 3.9.6 or 3.8.7, which fixes the issue.
Weakness: CWE-862
Which versions are affected by CVE-2026-79993?
1 open source package ship an affected version, including zookeeper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zookeeper Bitnami | From 3.8.0 | 3.8.7, 3.9.6 |
Products include Apache Zookeeper.
How do I fix CVE-2026-79993?
Upgrade zookeeper to a fixed version for your release line: 3.8.7 or 3.9.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-79993 being exploited?
There is no known exploitation of CVE-2026-79993 in the wild and no public exploit code.
Other vulnerabilities in Apache ZooKeeper
- CVE-2024-51504 Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server
- CVE-2023-44981 Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication
- CVE-2016-5017 Memory corruption in n/a
- CVE-2026-59739 Apache ZooKeeper: Information disclosure via SetWatches reconnect replay
- CVE-2026-59969 Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode
Sources
Also known as BIT-zookeeper-2026-79993, CLEANSTART-2026-GJ18736, CLEANSTART-2026-VL27493, CLEANSTART-2026-VR96593, CLEANSTART-2026-ZO47160, DEBIAN-CVE-2026-79993 and 4 more.