# CVE-2026-79993: Missing authorization in Apache ZooKeeper

> An unauthenticated attacker can delete any empty persistent znode in Apache ZooKeeper by bypassing ACL checks on the deleteContainer opcode.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-zookeeper-2026-79993, CLEANSTART-2026-GJ18736, CLEANSTART-2026-VL27493, CLEANSTART-2026-VR96593, CLEANSTART-2026-ZO47160, DEBIAN-CVE-2026-79993, GHSA-9x9g-5r48-3wvg, MINI-835h-854j-wh9h, MINI-qj34-rr98-fvmm, UBUNTU-CVE-2026-79993

## What is CVE-2026-79993?

CVE-2026-79993 is a high-severity missing authorization vulnerability in Apache ZooKeeper, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The `deleteContainer` opcode (0x14/20) is processed without verifying the caller's ACL permissions, allowing any authenticated client to delete specific znodes in the data tree regardless of the ACL restrictions on the znode or its parent. This opcode is considered internal-only and the official client doesn't have API for it, but a client that can open a plain TCP session on the ZooKeeper client port (2181 by default) - with NO authentication and NO ACL permissions - can delete any empty persistent znode (including regular persistent nodes, container nodes, and TTL nodes) by issuing the raw protocol OpCode deleteContainer (20). The deleteContainer request path completely skips both the session check and the DELETE ACL check that are enforced by the regular delete (OpCode 2) path. This is an authorization bypass / ACL enforcement bug.

This issue affects Apache ZooKeeper: from 3.9.0 through 3.9.5, from 3.8.0 through 3.8.6.

Users are recommended to upgrade to version 3.9.6 or 3.8.7, which fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-79993?

1 open source package ship an affected version, including zookeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zookeeper` | Bitnami | From 3.8.0 | 3.8.7, 3.9.6 |

Products: Apache Zookeeper.

## How do I fix CVE-2026-79993?

Upgrade zookeeper to a fixed version for your release line: 3.8.7 or 3.9.6.

## Is CVE-2026-79993 being exploited?

There is no known exploitation of CVE-2026-79993 in the wild and no public exploit code.

## Other vulnerabilities in Apache ZooKeeper

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-79993 and fix it if it is affected.

What it is: CVE-2026-79993 is a high-severity missing authorization vulnerability in Apache ZooKeeper, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-79993 in the wild and no public exploit code.

Affected packages and fixed versions:
- zookeeper (Bitnami): affected from 3.8.0; fixed in 3.8.7, 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-79993/ (Markdown: https://insights.sbomify.com/CVE-2026-79993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-79993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-79993
- OSV: https://osv.dev/vulnerability/CVE-2026-79993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-79993/
Summaries are generated and may contain mistakes; the official description above is the record.
