CVE-2026-80180 Apache Allura: Stored XSS via markdown HTML processing

Medium 6.1 Published Updated

Attackers can inject malicious scripts via markdown processing in Apache Allura, potentially stealing user sessions or executing code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-80180?

CVE-2026-80180 is a medium-severity cross-site scripting vulnerability in Apache Allura, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Stored XSS via markdown HTML processing in Apache Allura.

This issue affects Apache Allura: from through 1.20.0.

Users are recommended to upgrade to version 1.21.0, which fixes the issue.

Weakness: CWE-79

Which versions are affected by CVE-2026-80180?

How do I fix CVE-2026-80180?

No fix has been published for CVE-2026-80180 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-80180 being exploited?

There is no known exploitation of CVE-2026-80180 in the wild and no public exploit code.

Sources

Also known as GHSA-w8gw-2cgm-wv2h.

Is CVE-2026-80180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free