# CVE-2026-80196: Kimai before 2.58.0 Authentication Bypass via Password Reset Link

> Attackers can reuse intercepted password reset links to bypass authentication and take over user accounts even after password changes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-m492-gv72-xvxj, GHSA-vwp7-rf4h-hh34

## What is CVE-2026-80196?

CVE-2026-80196 is a high-severity authentication bypass vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kimai before 2.58.0 contains an authentication bypass vulnerability where password reset links remain valid after password changes because the LoginLink signature covers only the user id, not the password hash. Attackers who intercept or cache a password reset link can use it up to 2 additional times within a 1-hour window to log in as the user even after the legitimate user has changed their password.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2026-80196?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |

## How do I fix CVE-2026-80196?

Upgrade kimai/kimai to 2.58.0 or later.

## Is CVE-2026-80196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-80196 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-80196 and fix it if it is affected.

What it is: CVE-2026-80196 is a high-severity authentication bypass vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-80196 exists.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-80196/ (Markdown: https://insights.sbomify.com/CVE-2026-80196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-80196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-80196
- OSV: https://osv.dev/vulnerability/CVE-2026-80196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-80196/
Summaries are generated and may contain mistakes; the official description above is the record.
