# CVE-2026-80197: Kimai before 2.57.0 Improper Authorization via Favorite Endpoints

> Authenticated users can manipulate other users' favorite timesheet lists by referencing identifiers, allowing cross-user data tampering.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h76h-mxwq-v9xp, GHSA-j5mc-p8qg-39j7

## What is CVE-2026-80197?

CVE-2026-80197 is a high-severity missing authorization vulnerability in kimai, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai before 2.57.0 contains an improper authorization vulnerability in the favorite timesheet add and remove endpoints that allows authenticated users to manipulate other users' bookmarks. Attackers can add or remove timesheet entries from another user's favorite list by referencing their timesheet identifier, enabling cross-user business-state tampering without administrative privileges.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-80197?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |
| `kimai/kimai` | Packagist | All versions | 2.57.0 |

## How do I fix CVE-2026-80197?

Upgrade kimai/kimai to 2.57.0 or later.

## Is CVE-2026-80197 being exploited?

There is no known exploitation of CVE-2026-80197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-80197 and fix it if it is affected.

What it is: CVE-2026-80197 is a high-severity missing authorization vulnerability in kimai, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-80197 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.57.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-80197/ (Markdown: https://insights.sbomify.com/CVE-2026-80197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-80197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-80197
- OSV: https://osv.dev/vulnerability/CVE-2026-80197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-80197/
Summaries are generated and may contain mistakes; the official description above is the record.
