{"answers":{"affected":"2 open source packages ship an affected version, including kimai/kimai.","exploited":"There is no known exploitation of CVE-2026-80198 in the wild and no public exploit code.","fix":"Upgrade kimai/kimai to 2.56.0 or later.","what":"CVE-2026-80198 is a high-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-80198 and fix it if it is affected.\n\nWhat it is: CVE-2026-80198 is a high-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-80198 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kimai/kimai (Packagist): affected all versions; fixed in 2.56.0\n- kimai/kimai (Packagist): affected all versions; fixed in 2.56.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-80198/ (Markdown: https://insights.sbomify.com/CVE-2026-80198/index.md)","id":"CVE-2026-80198","markdown":"https://insights.sbomify.com/CVE-2026-80198/index.md","name":"CVE-2026-80198","record":{"aliases":["GHSA-vrqv-52x7-rm4v","GHSA-w754-75mx-556q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kimai time tracking","requires_auth":"none","summary":"Administrators can exfiltrate sensitive server secrets like LDAP passwords and SAML keys via malicious templates in Kimai.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"Kimai versions before 2.56.0 fail to restrict the config() Twig function in sandboxed invoice and export templates, allowing administrators to access arbitrary configuration keys. Attackers with admin privileges can upload malicious templates to exfiltrate server-wide secrets including LDAP bind passwords and SAML private keys into invoice or export documents accessible to lower-privileged users.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Kimai before 2.56.0 Information Disclosure via config() Twig Function","id":"CVE-2026-80198","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Kimai before 2.54.0 Username Enumeration via Timing Oracle","id":"CVE-2026-80199"},"packages":[{"ecosystem":"Packagist","fixed":["2.56.0"],"introduced":["0"],"last_affected":[],"package":"kimai/kimai","purl":null,"source":"GHSA-vrqv-52x7-rm4v"},{"ecosystem":"Packagist","fixed":["2.56.0"],"introduced":["0"],"last_affected":[],"package":"kimai/kimai","purl":"pkg:composer/kimai/kimai","source":"GHSA-vrqv-52x7-rm4v"}],"prev":{"headline":"Kimai before 2.57.0 Improper Authorization via Favorite Endpoints","id":"CVE-2026-80197"},"products":["kimai"],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["kimai"]},"summary":"Administrators can exfiltrate sensitive server secrets like LDAP passwords and SAML keys via malicious templates in Kimai.","url":"https://insights.sbomify.com/CVE-2026-80198/"}