# CVE-2026-80198: Kimai before 2.56.0 Information Disclosure via config() Twig Function

> Administrators can exfiltrate sensitive server secrets like LDAP passwords and SAML keys via malicious templates in Kimai.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-vrqv-52x7-rm4v, GHSA-w754-75mx-556q

## What is CVE-2026-80198?

CVE-2026-80198 is a high-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kimai versions before 2.56.0 fail to restrict the config() Twig function in sandboxed invoice and export templates, allowing administrators to access arbitrary configuration keys. Attackers with admin privileges can upload malicious templates to exfiltrate server-wide secrets including LDAP bind passwords and SAML private keys into invoice or export documents accessible to lower-privileged users.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-80198?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.56.0 |
| `kimai/kimai` | Packagist | All versions | 2.56.0 |

## How do I fix CVE-2026-80198?

Upgrade kimai/kimai to 2.56.0 or later.

## Is CVE-2026-80198 being exploited?

There is no known exploitation of CVE-2026-80198 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-80198 and fix it if it is affected.

What it is: CVE-2026-80198 is a high-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-80198 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.56.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.56.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-80198/ (Markdown: https://insights.sbomify.com/CVE-2026-80198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-80198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-80198
- OSV: https://osv.dev/vulnerability/CVE-2026-80198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-80198/
Summaries are generated and may contain mistakes; the official description above is the record.
