# CVE-2026-80200: Kimai before 2.53.0 Open Redirect via RelayState

> Attackers with IdP access can redirect authenticated Kimai users to malicious sites via unvalidated RelayState parameters, enabling phishing or credential theft.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3jp4-mhh4-gcgr, GHSA-wv9h-9jv8-rqm9

## What is CVE-2026-80200?

CVE-2026-80200 is a medium-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kimai before 2.53.0 contains an open redirect vulnerability in the SAML authentication success handler that accepts unvalidated RelayState POST parameters as redirect destinations. Attackers with IdP access can supply malicious RelayState values to redirect authenticated users to attacker-controlled URLs for credential theft or phishing attacks.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-80200?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.53.0 |
| `kimai/kimai` | Packagist | All versions | 2.53.0 |

## How do I fix CVE-2026-80200?

Upgrade kimai/kimai to 2.53.0 or later.

## Is CVE-2026-80200 being exploited?

There is no known exploitation of CVE-2026-80200 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-80200 and fix it if it is affected.

What it is: CVE-2026-80200 is a medium-severity vulnerability in kimai, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-80200 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.53.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-80200/ (Markdown: https://insights.sbomify.com/CVE-2026-80200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-80200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-80200
- OSV: https://osv.dev/vulnerability/CVE-2026-80200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-80200/
Summaries are generated and may contain mistakes; the official description above is the record.
