# CVE-2026-80201: Kimai before 2.53.0 API Token Leakage via Invoice Template

> Attackers with template creation permissions can leak API tokens by injecting method calls into Twig invoice templates in Kimai.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-hqh5-vhwr-rg24, GHSA-rh42-6rj2-xwmc

## What is CVE-2026-80201?

CVE-2026-80201 is a low-severity code injection vulnerability in kimai, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Kimai before 2.53.0 fails to block sensitive User methods in the Twig invoice template sandbox, allowing admins to call getApiToken() and getPlainApiToken() methods. Attackers with template creation permissions can embed these method calls in invoice templates to leak hashed API tokens in rendered invoice output.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-80201?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.53.0 |
| `kimai/kimai` | Packagist | All versions | 2.53.0 |

## How do I fix CVE-2026-80201?

Upgrade kimai/kimai to 2.53.0 or later.

## Is CVE-2026-80201 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-80201 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-80201 and fix it if it is affected.

What it is: CVE-2026-80201 is a low-severity code injection vulnerability in kimai, published on 25 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-80201 exists.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.53.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-80201/ (Markdown: https://insights.sbomify.com/CVE-2026-80201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-80201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-80201
- OSV: https://osv.dev/vulnerability/CVE-2026-80201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-80201/
Summaries are generated and may contain mistakes; the official description above is the record.
