{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-80343 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-80343 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-80343 is a high-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-80343 and fix it if it is affected.\n\nWhat it is: CVE-2026-80343 is a high-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-80343 in the wild and no public exploit code.\n\nAffected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-80343/ (Markdown: https://insights.sbomify.com/CVE-2026-80343/index.md)","id":"CVE-2026-80343","markdown":"https://insights.sbomify.com/CVE-2026-80343/index.md","name":"CVE-2026-80343","record":{"aliases":["GHSA-pvjg-pwh7-34pj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Camel library","requires_auth":"none","summary":"Attackers can bypass security constraints in Apache Camel Netty HTTP by altering path case, accessing protected routes without authorization.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-178","name":"Improper Handling of Case Sensitivity"}],"description":"Improper Handling of Case Sensitivity vulnerability in Apache Camel Netty HTTP component.\n\nThis issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nThe camel-netty-http security constraint compared the request path against the configured context path using a case-sensitive match, while the routing that dispatches the request to the endpoint did not apply the same rule. The two comparisons therefore disagreed for any path whose case differed from the configured value. An external caller could alter the case of a character in a path segment so that the security constraint no longer recognised the path as protected, while the request still dispatched to the same endpoint. The result is that the constraint is skipped and the protected route is reached without satisfying it. No credential, prior access or special configuration is required beyond being able to send a request to the consumer.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The constraint now matches the request path with the same case rules the dispatch uses, so the two can no longer disagree. For deployments that cannot upgrade immediately, place the authorization decision in front of the Camel consumer, for example in a reverse proxy that normalises the request path before forwarding.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2026-10-18","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-18T10:41:49Z","kind":"github_poc","ref":"https://github.com/oscerd/CVE-2026-80343","stars":0,"title":"Reproducer for CVE-2026-80343 (Apache Camel camel-netty-http): security constraint case-sensitivity bypass — altering the path case skips the constraint while routing still dispatches to the protected endpoint — Camel Spring Boot + Camel Quarkus"}],"tier":"poc_unverified"},"has_fix":false,"headline":"Apache Camel: Camel-Netty-HTTP Security Constraint Bypass via Case-Sensitive Context-Path Matching","id":"CVE-2026-80343","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"Apache Camel: Camel-AS2 Server-Side Request Forgery and Credential Disclosure via Asynchronous MDN Delivery Address","id":"CVE-2026-80344"},"packages":[],"prev":{"headline":"Payment Plugins for PayPal WooCommerce \u003c 2.0.27 - Unauthenticated Payment Hijacking via Unvalidated PayPal Order ID","id":"CVE-2026-80342"},"products":["Apache Camel"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass security constraints in Apache Camel Netty HTTP by altering path case, accessing protected routes without authorization.","url":"https://insights.sbomify.com/CVE-2026-80343/"}