CVE-2026-8053 FlatBSON Duplicate Field Index Drift

High 8.7 Published Updated

An authenticated user with write privileges can trigger an out-of-bounds memory write in MongoDB Server, potentially leading to arbitrary code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-8053?

CVE-2026-8053 is a high-severity memory corruption vulnerability in Mongodb Mongodb, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue in MongoDB Server's time-series collection implementation allows an authenticated user with database write privileges to trigger an out-of-bounds memory write in the mongod process. The issue results from an inconsistency in the internal field-name-to-index mapping within the time-series bucket catalog. Under certain conditions this can result in arbitrary code execution.

This issue impacts MongoDB Server v5.0 versions prior to 5.0.33, v6.0 versions prior to 6.0.28, v7.0 versions prior to 7.0.34, v8.0 versions prior to 8.0.23, v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.

Weakness: CWE-787

Which versions are affected by CVE-2026-8053?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.33, 6.0.28, 7.0.34, 8.0.23, 8.2.9, 8.3.2

Products include Mongodb Mongodb.

How do I fix CVE-2026-8053?

Upgrade mongodb to a fixed version for your release line: 5.0.33, 6.0.28, 7.0.34 or 8.0.23.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-8053 being exploited?

There is no known exploitation of CVE-2026-8053 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2026-8053, GHSA-pr63-cc36-q84h, MINI-3453-3h8w-c22h, MINI-8wcm-crm8-pq24, MINI-9cg3-3qwj-gpc8, UBUNTU-CVE-2026-8053.

Is CVE-2026-8053 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free