# CVE-2026-8074: Improper Permission Check Allows User Manager to Deactivate Bot Accounts

> User Managers can deactivate bot accounts without Integrations access due to missing permission checks on the user active status endpoint.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-g5vr-6pgg-74qv, GO-2026-6481

## What is CVE-2026-8074?

CVE-2026-8074 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to enforce bot-specific permission checks on the user active status endpoint, which allows a User Manager with user management write access but no Integrations access to deactivate bot accounts via the PUT /api/v4/users/{id}/active API endpoint.. Mattermost Advisory ID: MMSA-2026-00667

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-8074?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.18+incompatible, 11.7.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.7.0 | 11.7.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.7.0 | 11.7.1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-8074?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.18, 10.11.18+incompatible, 11.7.1+incompatible or 11.7.1.

## Is CVE-2026-8074 being exploited?

There is no known exploitation of CVE-2026-8074 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8074 and fix it if it is affected.

What it is: CVE-2026-8074 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8074 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.18
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.18
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.18+incompatible, 11.7.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.7.0; fixed in 11.7.1
- github.com/mattermost/mattermost-server (Go): affected from 11.7.0; fixed in 11.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8074/ (Markdown: https://insights.sbomify.com/CVE-2026-8074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8074
- OSV: https://osv.dev/vulnerability/CVE-2026-8074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8074/
Summaries are generated and may contain mistakes; the official description above is the record.
