# CVE-2026-8087: OSGeo gdal GDapi.c GDnentries heap-based overflow

> A heap-based buffer overflow in GDAL allows local attackers to execute arbitrary code or cause denial of service via manipulated data fields.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** AZL-86229, BIT-gdal-2026-8087, DEBIAN-CVE-2026-8087, ECHO-2fea-eb73-2884, GHSA-h9rh-5ffh-h669, JLSEC-2026-769, PYSEC-2026-2155, UBUNTU-CVE-2026-8087

## What is CVE-2026-8087?

CVE-2026-8087 is a medium-severity memory corruption vulnerability in OSGeo gdal, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A security flaw has been discovered in OSGeo gdal up to 3.13.0dev-4. Impacted is the function GDnentries of the file frmts/hdf4/hdf-eos/GDapi.c. Performing a manipulation of the argument DataFieldName results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 3.13.0RC1 is recommended to address this issue. The patch is named 184f77dbcc74118c062c05e464c88161d3c37b9b. You should upgrade the affected component.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-8087?

4 open source packages ship an affected version, including gdal and GDAL. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | Bitnami | All versions | 3.13.0 |
| `gdal` | PyPI | All versions | 3.13.0 |
| `gdal` | PyPI | All versions | 3.13.0 |
| `GDAL` | PyPI | All versions | 3.13.0 |

Products: Osgeo Gdal.

## How do I fix CVE-2026-8087?

Upgrade gdal to 3.13.0 or later.

## Is CVE-2026-8087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8087 exists.

## Other vulnerabilities in OSGeo gdal

- [CVE-2019-25050](https://insights.sbomify.com/CVE-2019-25050/): Memory corruption in n/a (high 7.8)
- [CVE-2026-49014](https://insights.sbomify.com/CVE-2026-49014/): GDAL: scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow (high 7.4)
- [CVE-2025-29480](https://insights.sbomify.com/CVE-2025-29480/): Memory corruption in n/a (medium 5.5)
- [CVE-2026-8212](https://insights.sbomify.com/CVE-2026-8212/): OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8213](https://insights.sbomify.com/CVE-2026-8213/): OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8087 and fix it if it is affected.

What it is: CVE-2026-8087 is a medium-severity memory corruption vulnerability in OSGeo gdal, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8087 exists.

Affected packages and fixed versions:
- gdal (Bitnami): affected all versions; fixed in 3.13.0
- gdal (PyPI): affected all versions; fixed in 3.13.0
- gdal (PyPI): affected all versions; fixed in 3.13.0
- GDAL (PyPI): affected all versions; fixed in 3.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8087/ (Markdown: https://insights.sbomify.com/CVE-2026-8087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8087
- OSV: https://osv.dev/vulnerability/CVE-2026-8087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8087/
Summaries are generated and may contain mistakes; the official description above is the record.
