# CVE-2026-8088: OSGeo gdal GDapi.c GDfieldinfo out-of-bounds

> A local attacker can trigger an out-of-bounds read in GDAL's HDF-EOS handler, potentially exposing memory or causing a crash.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** AZL-86232, BIT-gdal-2026-8088, DEBIAN-CVE-2026-8088, ECHO-1eea-bb40-c2e4, GHSA-j3f5-rw74-g4rv, JLSEC-2026-770, PYSEC-2026-2156, UBUNTU-CVE-2026-8088

## What is CVE-2026-8088?

CVE-2026-8088 is a medium-severity memory corruption vulnerability in OSGeo gdal, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A weakness has been identified in OSGeo gdal up to 3.13.0dev-4. The affected element is the function GDfieldinfo of the file frmts/hdf4/hdf-eos/GDapi.c. Executing a manipulation can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.13.0RC1 is sufficient to fix this issue. This patch is called a791f70f8eaec540974ec989ca6fb00266b7646c. The affected component should be upgraded.

Weakness: CWE-125 (Out-of-bounds Read), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-8088?

4 open source packages ship an affected version, including gdal and GDAL. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | Bitnami | All versions | 3.13.0 |
| `gdal` | PyPI | All versions | 3.13.0 |
| `gdal` | PyPI | All versions | 3.13.0 |
| `GDAL` | PyPI | All versions | 3.13.0 |

Products: Osgeo Gdal.

## How do I fix CVE-2026-8088?

Upgrade gdal to 3.13.0 or later.

## Is CVE-2026-8088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8088 exists.

## Other vulnerabilities in OSGeo gdal

- [CVE-2019-25050](https://insights.sbomify.com/CVE-2019-25050/): Memory corruption in n/a (high 7.8)
- [CVE-2026-49014](https://insights.sbomify.com/CVE-2026-49014/): GDAL: scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow (high 7.4)
- [CVE-2025-29480](https://insights.sbomify.com/CVE-2025-29480/): Memory corruption in n/a (medium 5.5)
- [CVE-2026-8212](https://insights.sbomify.com/CVE-2026-8212/): OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow (medium 4.8)
- [CVE-2026-8213](https://insights.sbomify.com/CVE-2026-8213/): OSGeo gdal Grid File GDapi.c GDSDfldsrch heap-based overflow (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8088 and fix it if it is affected.

What it is: CVE-2026-8088 is a medium-severity memory corruption vulnerability in OSGeo gdal, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8088 exists.

Affected packages and fixed versions:
- gdal (Bitnami): affected all versions; fixed in 3.13.0
- gdal (PyPI): affected all versions; fixed in 3.13.0
- gdal (PyPI): affected all versions; fixed in 3.13.0
- GDAL (PyPI): affected all versions; fixed in 3.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8088/ (Markdown: https://insights.sbomify.com/CVE-2026-8088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8088
- OSV: https://osv.dev/vulnerability/CVE-2026-8088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8088/
Summaries are generated and may contain mistakes; the official description above is the record.
