{"answers":{"affected":"2 open source packages ship an affected version, including devalue.","exploited":"There is no known exploitation of CVE-2026-81176 in the wild and no public exploit code.","fix":"Upgrade devalue to 5.9.2 or later.","what":"CVE-2026-81176 is a medium-severity denial of service vulnerability in sveltejs devalue, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-81176 and fix it if it is affected.\n\nWhat it is: CVE-2026-81176 is a medium-severity denial of service vulnerability in sveltejs devalue, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-81176 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devalue (npm): affected all versions; fixed in 5.9.2\n- devalue (npm): affected all versions; fixed in 5.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-81176/ (Markdown: https://insights.sbomify.com/CVE-2026-81176/index.md)","id":"CVE-2026-81176","markdown":"https://insights.sbomify.com/CVE-2026-81176/index.md","name":"CVE-2026-81176","record":{"aliases":["CLSA-2026-1789752547","CLSA-2026-1792231082","CLSA-2026-1792231273","GHSA-9rgm-9g3h-6x36"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript serialization library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using Svelte devalue by sending specially crafted payloads that trigger quadratic processing time.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Svelte devalue: DoS via malformed input","id":"CVE-2026-81176","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"SysReptor: Anonymous note-share link discloses project member identities and non-shared note activity","id":"CVE-2026-81178"},"packages":[{"ecosystem":"npm","fixed":["5.9.2"],"introduced":["0"],"last_affected":[],"package":"devalue","purl":null,"source":"GHSA-9rgm-9g3h-6x36"},{"ecosystem":"npm","fixed":["5.9.2"],"introduced":["0"],"last_affected":[],"package":"devalue","purl":"pkg:npm/devalue","source":"GHSA-9rgm-9g3h-6x36"}],"prev":{"headline":"CAPTCHA Protected Page - Moderately critical - Cookie Forgery - SA-CONTRIB-2026-105","id":"CVE-2026-81168"},"products":["devalue"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["sveltejs"]},"summary":"Attackers can cause denial of service in applications using Svelte devalue by sending specially crafted payloads that trigger quadratic processing time.","url":"https://insights.sbomify.com/CVE-2026-81176/"}