# CVE-2026-81176: Svelte devalue: DoS via malformed input

> Attackers can cause denial of service in applications using Svelte devalue by sending specially crafted payloads that trigger quadratic processing time.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLSA-2026-1789752547, CLSA-2026-1792231082, CLSA-2026-1792231273, GHSA-9rgm-9g3h-6x36

## What is CVE-2026-81176?

CVE-2026-81176 is a medium-severity denial of service vulnerability in sveltejs devalue, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-81176?

2 open source packages ship an affected version, including devalue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devalue` | npm | All versions | 5.9.2 |
| `devalue` | npm | All versions | 5.9.2 |

## How do I fix CVE-2026-81176?

Upgrade devalue to 5.9.2 or later.

## Is CVE-2026-81176 being exploited?

There is no known exploitation of CVE-2026-81176 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81176 and fix it if it is affected.

What it is: CVE-2026-81176 is a medium-severity denial of service vulnerability in sveltejs devalue, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81176 in the wild and no public exploit code.

Affected packages and fixed versions:
- devalue (npm): affected all versions; fixed in 5.9.2
- devalue (npm): affected all versions; fixed in 5.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81176/ (Markdown: https://insights.sbomify.com/CVE-2026-81176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81176
- OSV: https://osv.dev/vulnerability/CVE-2026-81176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81176/
Summaries are generated and may contain mistakes; the official description above is the record.
