# CVE-2026-81180: SysReptor: Authenticated RCE by insecure image processing

> Authenticated users can achieve remote code execution by uploading malicious images that trigger Ghostscript and race conditions in GnuPG configuration.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-wmf3-gv8j-7qp7

## What is CVE-2026-81180?

CVE-2026-81180 is a high-severity code injection vulnerability in Syslifters sysreptor, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SysReptor is a fully customizable pentest reporting platform. Prior to 2026.61, authenticated users of SysReptor Professional can upload image files whose formats cause image processing to invoke Ghostscript, allowing embedded PostScript to operate in the shared temporary directory. An attacker can combine that behavior with a race involving GnuPG configuration files in temporary subdirectories to cause GnuPG to copy attacker-controlled Python code into the application code directory. The injected code executes with the privileges of the SysReptor application process after a worker restart. The Community edition is not affected. Version 2026.58 contains a partial mitigation, and this issue is fully fixed in version 2026.61.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-81180?


## How do I fix CVE-2026-81180?

No fix has been published for CVE-2026-81180 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-81180 being exploited?

There is no known exploitation of CVE-2026-81180 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81180 and fix it if it is affected.

What it is: CVE-2026-81180 is a high-severity code injection vulnerability in Syslifters sysreptor, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81180 in the wild and no public exploit code.

Affected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81180/ (Markdown: https://insights.sbomify.com/CVE-2026-81180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81180
- OSV: https://osv.dev/vulnerability/CVE-2026-81180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81180/
Summaries are generated and may contain mistakes; the official description above is the record.
