# CVE-2026-81316: Same-named aggregates with differing filters are conflated in AshSql

> Attackers can bypass authorization filters to read aggregate data across tenancy boundaries due to query conflation in AshSql.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-81316, GHSA-v7pf-wjxc-7j5m

## What is CVE-2026-81316?

CVE-2026-81316 is a low-severity missing authorization vulnerability in ash-project ash_sql, published on 30 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash_sql allows a caller to receive an aggregate value computed over rows a more restrictive filter should have excluded, disclosing counts, sums, or lists across an authorization or tenancy boundary.

AshSql.Aggregate.different_queries?/2 reports two aggregate queries as different only when their filter and their sort both differ. Aggregate queries rarely carry a sort, so two aggregates that share a name but carry entirely different filters compare as identical. The colliding aggregate keeps its name and is treated as already computed, and select_aggregates returns the first-registered variant's value. The same name reaches the builder twice with different filters when actor or tenant context is stamped into each aggregate's query, so a narrowly filtered aggregate can be served the value of a previously registered broad one.

This issue affects ash_sql: from 0.1.0 before 0.7.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-81316?

1 open source package ship an affected version, including ash_sql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_sql` | Hex | From 0.1.0 | 0.7.1 |

## How do I fix CVE-2026-81316?

Upgrade ash_sql to 0.7.1 or later.

## Is CVE-2026-81316 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81316 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81316 and fix it if it is affected.

What it is: CVE-2026-81316 is a low-severity missing authorization vulnerability in ash-project ash_sql, published on 30 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81316 exists.

Affected packages and fixed versions:
- ash_sql (Hex): affected from 0.1.0; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81316/ (Markdown: https://insights.sbomify.com/CVE-2026-81316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81316
- OSV: https://osv.dev/vulnerability/CVE-2026-81316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81316/
Summaries are generated and may contain mistakes; the official description above is the record.
