# CVE-2026-8134: Concrete CMS Vulnerable to Relative Path Traversal

> Authenticated administrators can achieve remote code execution via path traversal in Composer form layouts combined with insufficient file upload validation.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-645j-cm4x-3xvw

## What is CVE-2026-8134?

CVE-2026-8134 is a critical path traversal vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Concrete CMS 9.5.0 and below fails to sanitize path traversal sequences in the ptComposerFormLayoutSetControlCustomTemplate field when saving page type composer form layouts. An authenticated rogue administrator with composer form editing rights can exploit this to include arbitrary readable files on the server. Combined with the file uploader's extension-only validation (which permits PHP code in files saved with image extensions like .png), this can result in authenticated remote code execution. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 9.4 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H   Thanks Yonatan Drori (Tenzai) for reporting.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-8134?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2026-8134?

Upgrade concrete5/concrete5 to 9.5.1 or later.

## Is CVE-2026-8134 being exploited?

There is no known exploitation of CVE-2026-8134 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2022-30117](https://insights.sbomify.com/CVE-2022-30117/): Path traversal in Concrete CMS (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8134 and fix it if it is affected.

What it is: CVE-2026-8134 is a critical path traversal vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8134 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8134/ (Markdown: https://insights.sbomify.com/CVE-2026-8134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8134
- OSV: https://osv.dev/vulnerability/CVE-2026-8134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8134/
Summaries are generated and may contain mistakes; the official description above is the record.
